Follow

GoVoip Minimum Requirements

The system requirements for the Android and IOS GoVoip app are below. 

ioS version 13 and higher

Android OS 9.0 and higher

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.